Please update your AMD Radeon driver
September 4, 2016 Fix

Battlefield 1 error: please update your AMD Radeon driver
Battlefield 1 Detected AMD Radeon driver version 15.20.1062. The required driver version is 16.20.1025 or later. Please update your drivers at before playing the game.


This is a EA joke, as obviously you have the latest video card drivers. To solve the problem, run regedit.exe with administrative elevation. Registry editor opens, here navigate to this branch named Video.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video
Here you have to search for ReleaseVersion. The location differs depending on OS and hardware, so search for. Then open to edit, and change the initial number to the required driver version or higher. Just enter the digits. Exit regedit, restart the PC and now the game launches. If now it says The program stopped working, this is a completely different story, which I cover in another video.

Leave a Reply

You must be logged in to post a comment.

*